Authentisign Incident

Incident Report for Lone Wolf Technologies

Resolved

Service to Authentisign has been fully restored. Thank you for your patience and understanding.
Posted Jul 29, 2025 - 20:41 EDT

Investigating

Authentisign is currently experiencing an issue. Our team is aware and working to restore service as quickly as possible.
Posted Jul 29, 2025 - 20:06 EDT
This incident affected: Transaction Management (TMS) (Authentisign 2.0, Transactions (TransactionDesk Edition), Transactions (zipForm Edition)).