Front Office Incident

Incident Report for Lone Wolf Technologies

Resolved

This incident has been resolved.
Posted Jun 19, 2025 - 14:47 EDT

Investigating

Our team is actively investigating an issue affecting Front Office (PBGO). We're working to resolve it as quickly as possible and will provide updates here as we learn more. We appreciate your patience and apologize for the disruption.
Posted Jun 19, 2025 - 14:37 EDT
This incident affected: Propertybase (Front Office (Formerly GO)).